wdavince – Window Interface to DaVince Tools

Version: 3.0

Part of DaVince Tools
Web Site: www.davince.com

Last Modified: July 8, 2004

Command Syntax:

(Please note that the square brackets "[" and "]" specify optional parameters; do not enter the brackets as part of the command)

method 1: wdavince [-m] [file1] [file2] … [filen]


method 2: wdavince [-m] file.dcf


method 3: wdavince -e file.dcf


-m: Start program in minimized state
-e:  Open the DCF file for editing or viewing instead of execution. The file is opened with the viewer specified in wdavince's preferences window.


file1, file2, filen: Specify the name(s) of a file to be converted

file.dcf : A DCF file to execute when first starting up the program (must have a ".dcf" extension)
Use method 1 to open the wdavince application normally. Any files specified on the command line will be added to the files screen.  Use method 2 to automatically execute a DCF file upon startup. The -m option can be used to minimize the application on startup. Use method 3 to edit or view an existing DCF file with the viewer specified in the preferences window. The main wdavince window is not used with this method.


wdavince is a Windows application used for converting files to PDF. It provides a single window interface for both DaVince Tools and DaVince Tools Plus, as well as all the sample and bonus programs. wdavince is the program most users will use to run the DaVince Tools converter programs.  The install program optionally creates shortcuts to wdavince in the user's programs menu and desktop for easy access.  The features of this application include: DaVince Tools Plus settings are enabled in wdavince when selecting the "Plus" option in the DaVince Tools installation program. Enabling these "Plus" settings adds the file2pdf converter to the converters list as well as adds the DLL sample programs to the tools menu. Installing the "Plus" settings only displays these options, it does not change the registration status. You will need to register DaVince Tools Plus if you decide to use this program and remove the unregistered annotations that may appear in the "Plus" applications.

The window interface is divided into three screens: Settings, Files and Output. Switching between these screens is easily done by selecting the appropriate tab.  The conversion settings are specified in the Settings screen.  This includes the converter and profile settings, PDF title and web optimization settings.  The Files screen is where the files and/or folders to be converted are specified.  Folders and files can be dragged into this window, either from the wdavince window itself or from other document windows.  The Output screen displays output from conversions and output from programs in the Tools menu.  The wdavince window can be minimized while a program is running and optionally notify a user when a program has completed by either a sound notification or dialog box (new in version 3).  Below is a picture of wdavince's three screens:

Screenshot of GUI DaVince Tools interface


 Converter Options

Converter and Profile Select appropriate converter and profile. This is automatically filled in with the first file added to the conversion list ("default" profile is assumed). A description of the profile is displayed if a "description" option is included in the profile.
Title, Subject, Author, Keywords The title, subject, author and keywords fields that will be filled in the newly created PDF file.
Create 1 PDF for: All Files, Each File, Each Folder  Either combine multiple files into one PDF, create one PDF for each file, or create one PDF for each folder, respectively.
Include Subfolders Include all subfolders when converting folders.
Overwrite Existing PDF Files Used when "Each File" is set, disabling this option will skip converting a file if the resulting PDF file already exists AND the PDF file date is newer than the original file date.
Open PDF After Conversion Used when "All Files" is set, enabling this option will automatically launch the PDF viewer with the just converted PDF file.
Output PDF File/Output Directory When "All Files" is set, "Output PDF File" specifies the PDF filename to create. If blank, the name of the PDF file will be the converter's default name. For example, "tiff.pdf" is the default name when converting TIFF files. 

When "Each File" or "Each Folder" is set, "Output Directory" specifies the folder where the newly created PDF files will be stored. If left blank, the PDF files will be stored in the same directory as the data file or folder.

Web Optimize
When on, web optimize the newly created PDF file. This overrides the profile setting unless "Use Profile Setting" is enabled.
When on, create 1 bookmark for each file converted. When used with the "All Files" option, several bookmarks are created in each created PDF file.  This overrides the profile setting unless "Use Profile Setting" is enabled.
Image Thumbnails
When on, create thumbnails when converting images.  This overrides the profile setting unless "Use Profile Setting" is enabled.


Menu Options

File Menu:  
Save to DCF… Save current settings to a DaVince command file. This command file can be executed later by using the "Run Command File…" menu option.
Exit Exit the Program
Edit Menu:  
Reset Fields Reset fields to their default value
Set program preferences, including preferences for notification, and output screen font size
Refresh Refreshes directory and file lists
Cut, Copy, Paste Cut, copy or paste field data to or from the clipboard
Run Menu:  
Run Convert the specified files
Run Command File… Execute a DaVince command file.These files can be created manually or automatically using the "Save to DCF…" menu option.
Watch Folder(s)… Display watch folder window.
Cancel Program
Used to cancel a currently running program.
Tools Menu This menu is customizable, which is used to launch other applications. It may also be completely removed if desired. The default installation includes menu items for opening PDF files, modifying profile settings, and the tiffdump program. Depending on the installation, DaVince Tools Plus and PDF game menu items may also be included.
Help Menu  
DaVince Tools Help… On-line help in HTML format
DaVince Home Page Product web site
Tip of the Day… Display tip of the day window
Register Link to registration information
Install License Key… Prompt for the license key received when registering the product and install it.
About DaVince Tools… A dialog box displaying the version number and the registration status.


How to Specify Files or Folders for Conversion

There are several ways in which a file or folder can be specified for conversion: Files and folders listed in the conversion box can be reordered by dragging and dropping them from within the same window. Files and folders can be removed from the conversion box by clicking on them and pressing the <Delete> key, or right clicking on them and choosing the delete option from the popup menu.
Renaming the file in the conversion box changes the bookmark name. Use the blackslash character "\" to create a bookmark hierachy.

Using the Watch Folders Feature

The watch folders feature can be accessed by either selecting the item under the run menu or by clicking on the appropriate button in the button bar. The watch folder window appears as follows:

This feature allows one to have a folder watched for incoming files. As files appear in one or more defined folders, they are converted to PDF using the specified converter and profile.  For a frequently watched folder, the settings can be saved to a DCF file using the "Save…" button. This allows the folder to be watched later by using the "Run Command File…" menu option and specifying this DCF file. After conversion, the original file can be moved from the watch folder to the PDF folder, it can be deleted, or it can be left alone.

Under the "Edit" menu, the single option "Reset Fields" resets all fields (except the watch folders field) to the original settings.

Limitations of the Unregistered Version

The unregistered version of "DaVince Tools" allows full use of all program features. Unregistered copies will create an unregistered notice within the PDF file, and the Windows application will notify the user of its unregistered status after each conversion. This notice within the PDF file will disappear for all future conversions after you register your copy of "DaVince Tools". Previous conversions will have to be re-run in order to remove the unregistered notice. You are encouraged to register your software by clicking on the "Register" menu item under the "Help" menu.

Customizing the Tools Menu

The Tools menu is completely customizable. It can also be removed from the application if desired. The Tools menu is defined in the wdavince.ini file. It is located in the "[toolsmenu]" section. To remove the tools menu, rename the "[toolsmenu]" name or delete the section in its entirety (for example: renaming to "[_toolsmenu]" will remove the menu from the program). Below is a sample line from the "[toolsmenu]" section:

010=title:"TIFF Dump",exe:"tiffdump.exe %i%",inputext:tif,input:"TIFF file(*.tif,*.tiff)|*.tif;*.tiff",params:"console,open"

The first parameter in the line ("010") specifies the ordering sequence of the item in the Tools menu. The actual value is not important, but its ordering sequence is important. The ordering sequence is based on the alphanumeric sorting sequence of the items and does not need to be sequential. Alphanumeric sorting requires leading zeros in numbers. This means a sequence value of "15" would appear before a value of "3", but not "03".

The sequence value is followed by an equals sign ("="). This is then followed by a series of comma delimited parameters used for defining the menu item. The following parameters are allowed for defining the tool menu item:
title The title to use in the menu. Create the shortcut character by inserting an ampersand character (&) before the shortcut character. To create a separator bar in the menu, use a single dash as its title ("-")
exe The filename of a data file or executable file with any associated parameters. It should be located either in the "DaVince Tools" exe directory, or it should be in the path, otherwise, the full pathname must be specified. Single quotes should surround the data file or executable file name if the path contains spaces.

The following variables can be used:

The home directory of the wdavince program
input filename - when present, a dialog box will be presented requesting an existing file. Uses input and inputext params.
number - when present, a dialog box will be presented requesting a number. Use m, x and t options to define minimum number, maximum number and prompt text, respectively. For example:

%n:m:1,x:100,t:Enter a number between 1 and 100%
output filename - when present, a dialog box will be presented requesting a new, non-existing file. Uses output and outputext params.

priority Priority value for the converter. Priority is used to when guessing the converter to use when none has been specified and a file has just been dropped into the conversion window.  If two or more converters share a common file type, the converter with the higher priority will be chosen over one with a lower priority. For example, both tiff2pdf and file2pdf convert tiff files. If tiff2pdf has a higher priority specified, then it will be chosen over file2pdf.
input The filter definition to be used in the open dialog box.
inputext The default file extension to be used with the input file.
output The filter definition to be used in the save dialog box.
outputext The default file extension when creating the output file, which is used by the save dialog box.
params Additional comma delimited parameters that can be used to define the behavior of the tool. This item must be enclosed in quotes since it uses the same delimiter. These parameters are: 

console - Run the tool in the "DaVince Tools" console window. 

open - open the output file with its default viewer. For example, a PDF file will be opened by Acrobat Reader or Exchange. When using the open parameter with "exe" parameter, you must include the "%o" option in order for this to work. To open an existing file (i.e. a previously created PDF file), include the inputext and input parameters (the exe parameter is not needed).  Snother way to open an existing file is to include the inputext, input and exe parameter of "%i" (the params parameter is not needed in this case).


About DaVince Tools:

Visit the DaVince Tools web site at http://www.davince.com for the latest version of this software and the latest documentation. DaVince Tools is shareware and software registration is urged if you find these programs useful. You can register the software on-line at http://www.davince.com.

DaVince Tools was written in C++ using the DaVince Class Library, written by the same author as this program. The DaVince Class Library is a C++ library for developing PDF and TIFF applications. Contact the author at info@davince.com for more information on the availability of the class library.